dcsimg

Data protection

Internet browser security

The payment industry and internet community are upgrading security. Soon you will no longer be able to connect to on-line services using the SSLv3 protocol.

For the majority of online customers this will mean no change. The SSLv3 protocol is considered insecure and is no longer supported by many browsers.

You should ensure your browser (or other software) is capable of using and configured to use 'Transport Layer Security' (TLS) 1.1 or above, (TLS1.1 and 1.2).

If you are uncertain about the type of secure connection your browser or other software can support, you can check it at How's my SSL.

When sensitive data such as cardholder data is sent over the internet it must be encrypted to deter criminal activity and reduce the chance of data theft/ fraud.

In order to do this and to comply with the PCI DSS requirements, we have to keep our network and applications up-to-date with the latest security protocols.

This is not an action Harrow Council is taking alone. Every website that transmits or processes credit card data will be making this change..

If you are using an old browser or an old version of Android or iOS on your phone, it might not be compatible with the current TLS v1.2 or above and if this is the case you might not be able to communicate with certain areas of our websites.

In order to maintain a connection with our (and other peoples) systems you might need to upgrade your browser. Below is a list of the minimum browser version you need to be compliant.

  • Chrome - v30 supports TLS 1.2
  • Firefox - v27 enables TLS 1.1 and 1.2 by default
  • Internet Explorer - v11 supports TLS 1.2 from Feb 2013
  • Opera - v17 has added support for TLS 1.2
  • Safari - v5 on iOS and v7 on OS X have added support for up to TLS 1.2
  • Android – v5 and upwards support TLS 1.2
  • Apple mobile iOS – iOS 5 and upwards supports TLS 1.2

How do I update my internet browser?

Keeping your Internet browser up-to-date is important for both security and ensuring that web pages load properly.

We also recommend that you update any plug-ins, extensions, or other add-ons you have installed.

You can visit the 'Browse Happy' website for help on how you can upgrade your internet browser.